November 20, 2019        Login     
 Blogs   
en-AUen-US
 

Welcome to the Blog page.

Please note: You need to be a registered user to be able to comment on blog entries

Blog Entries Minimize
By Nigel on Monday, 28 September 2009 7:07 PM

Was a nice afternoon for flying, I only had time for one flight though.

I flew in the driveway which was  tight considering the bins were out for the night.

I did some fast and slow piros and some small figure 8's

Battery #5 took 1548 ma to charge in 78:48 minutes for a 7 minute flight

By Nigel on Saturday, 19 September 2009 10:35 AM
Well this was the first flights with the new servos (Ino-Labs D760MG) and KDE bearing block upgrade.  I would have liked calmer conditions, so I could trim the heli, but it seemed pretty right.  A calm day will tell.

It was nice to have my Dad there to watch me fly too.

I did have to feed in quite a bit of forward cyclic, but im not sure if this was due to the wind or required trimming.

Once I was happy with it all, I did some piros (fast and slow), nose, left and right side in hovering and some cicuits.

...
By Nigel on Thursday, 17 September 2009 11:58 PM
I purchased some new faster servos for the Trex600n (Ino-Labs HG-D760MG), as well as the KDE Direct - Thrusted main shaft bearing block upgrade.  Parts were purchased from RC-Bits.  I was extremely impressed with the speed of delivery.  I ordered them on Tuesday night, and they arrived today, so well done RC-Bits.

All parts went in easily.  I did have to move the rx back about 2cm as the rear elevator servo wire barely reached.  The Ino-Lab servo leads are about 5cm shorter than the Hitecs.  I tried doing some setup to test everything, but the noise was too much for me to bear with my migraine, so will have to do the setup tomorrow night.

...
By Nigel on Saturday, 5 September 2009 10:23 AM
Wasn't the greatest conditions for flying. The winds weren't too bad, but did swing round from the north to the east.

I managed 2 flights, 11 and 9 minutes each.  Nothing new with todays flights, just some hovering and then some circuits.

I guess the only other things was some forced autos.  When switching from idle-up to normal flight modes, the engine would reduce revs (as per the governor setting) then after about 5 cedonds, it would just stop.  It wasn't like it was suddenly running...
 
  Copyright 2008-2010   Terms Of Use  Privacy Statement